TimescaleDB update

Hi, i’m trying make update of timescale extension on \psql (15.2 (Debian 15.2-1.pgdg100+1))
starting with psql -X -U postgres -h localhost
ERROR: extension “timescaledb” has no update path from version “2.10.1” to version “2.11.0”
but …
SELECT * FROM pg_available_extensions where name=‘timescaledb’;
name | default_version | installed_version | comment
timescaledb | 2.11.0 | 2.10.1 | Enables scalable inserts and complex queries for time-series data (Community Edition)
(1 row)
what can be wrong?

almost same issue here. any process?

im using ubuntu and postgresql 12 running this command
apt install timescaledb-2-postgresql-12=‘2.11.0’
helps me. im not familiar with postgres that much. maybe your problem is mine also.
after that
ALTER EXTENSION timescaledb UPDATE TO ‘2.11.0’; works

Thanks, but for me upgrading apt install not helped. Still no update path :roll_eyes:

can you check this path /usr/share/postgresql/12/extension/ . you must make sure there is extension and path for example for me timescaledb–2.9.2–2.11.0.sql should be there because i want to upgrade from 2.9.2 to 2.11.0
please confirm for you there is
as i noticed you only can update to version which has this. here is an screenshot of mine

before having this file im getting same error. or maybe you have another path like timescaledb–2.10.1–2.11.1.sql which you could use.

also im not sure but maybe update timescaledb toolkit have any effect in that.

sorry for my bad english i hope it was clear enough for what i mean