TimescaleDB Integration Issue - Timescale Community Forum

I am currently working on integrating TimescaleDB into my website’s backend, but I’ve run into an unexpected issue. I followed the documentation provided by TimescaleDB, but I’m encountering difficulties in establishing a successful connection and performing basic operations.

Error Details:
When attempting to connect to the TimescaleDB database from my web application, I receive the following error:

Error: could not establish connection to database ‘mydatabase’ on host ‘localhost’ with user ‘myuser’: FATAL: no pg_hba.conf entry for host “x.x.x.x”, user “myuser”, database “mydatabase”, SSL off

Steps Taken:

  1. I verified that the TimescaleDB extension is properly installed on my PostgreSQL database server.
  2. Checked the database connection parameters in my web application configuration file and confirmed their accuracy.
  3. Examined the PostgreSQL server logs for any additional error messages, but the provided message seems to be the main issue.

I would greatly appreciate any insights or suggestions from the TimescaleDB community on how to address this connection issue. If anyone has encountered a similar problem or has recommendations for troubleshooting, your assistance would be invaluable. Thank you!

Hi @joeroot, it seems like you have an auth problem that is related to your db.

When it says x.x.x.x is it literal? have you checked the pg_hba.conf content related to the connection?

You’ll see a message like

allow <ip address> <context> <permission>

My guess is that some of the permissions are not right. The pg_hba.conf file controls which hosts can connect to the database, which databases they can access, and how they can authenticate. You need to find this file in your PostgreSQL installation directory and open it with a text editor. It’s usually located in the data directory of your PostgreSQL installation.

You can update pg_hba.con and verify/add a new line to this file that allows your specific host, user, and database to connect. The general format is:

host database user  address auth-method  [auth-options]
  • For your case, it might look something like:
host mydatabase myuser x.x.x.x/32 md5

Remember to replace x.x.x.x with your actual client IP address. The /32 is a CIDR notation that represents a single IP address.

  • The auth-method can vary (like md5, password, scram-sha-256, or trust). Choose one that suits your security requirements. For SSL connections, you might use md5 or scram-sha-256.

Also, the error message indicates “SSL off”. If your organization’s policy requires encrypted connections, you should enable SSL in your PostgreSQL configuration. To enable SSL, you’ll need to set ssl = on in your postgresql.conf file and restart the server. You’ll also need to have the necessary SSL certificates in place.

Also, try to go deeper into the networking issue. If you don’t receive a response, there might be a network connectivity issue. Check if the server is up and running and if it’s accessible over the network.

This blog may help :slight_smile:

I appreciate your insight into the authentication issue and the suggestion to check the pg_hba.conf file. The IP address “x.x.x.x” was used as a placeholder, but I will indeed verify the actual IP address and review the permissions specified in the pg_hba.conf file accordingly.

Your explanation of the format for adding a new line to pg_hba.conf is very helpful, and I’ll make sure to update it with the appropriate settings for my specific host, user, and database. Additionally, I’ll consider enabling SSL connections if it aligns with the security requirements of my organization.

1 Like

Network issues can easily become hard and complex, feel free to come back anytime if you still need help.