Timescaledb conversion taking a long time for Zabbix Postgresql database (a lot of system resources are free)

I am trying to migrate Zabbix postgresql database to Timescaledb (5 TimescaleDB setup) but the whole process has been super slow and it takes days to complete.

I have tried using the timescaledb-tune utility or even manually adding aggressive values but the timescaledb conversion still wont utilize the resources on the host. The CPU never gets above 5% and allocating more memory to PostgreSQL does not help.

shared_buffers=50% of the system memory
max_worker_processes= 200
ma_parallel_workers_per_gather = 2
max_parallel_workers= 4

Am I missing something? Any help with how I can make Timescaledb use most of the system resources for the Timescaledb conversion is appreciated!

Hello @sysadm :wave:

Can you share more details about how much data you have, what is your process on migrating?

It seems the link that you posted is related to a page maintained by Zabbix. Have you tried asking more details about it in their community?

btw, smart nickname :smiley:

Hey @jonatasdp :wave:

About 700 GB data and took about 5 days to complete the Timescaledb conversion.

I have not asked yet but I will post it there. I was thinking about this relating to tuning Timescaledb but maybe someone in Zabbix community has a clue as well.

Thanks, I was surprised it wasn’t taken :slight_smile:
I may like to add, Timescaledb is awesome and we have seen a HUGE performance boost in a testing instance, but I want to figure out the bottleneck with the migration itself :slight_smile:

1 Like

Thanks for the feedback, and if you have any insights about how to resolve it, please, also cross post it here, as it can help other people in the community too!

To be honest I’m not familiar with how zabbix uses Timescale behind the scenes, but looking forward to learn more about it :nerd_face: