Fedora 39 [Halp]

Hey there team,

Looks like there is currently no installation method that will allow Timescale to run natively on Fedora 39 in Timescale license mode.

  1. You can install timescale and postgres with the native fedora repos, however its not bundled with the community license so half of the features don’t get packaged. Additionally it seems like there is no documentation on how these

  2. The Fedora instructions in the Timescale setup page simply don’t work. Once you’ve set up access to the repos etc. it cannot find a suitable deb. If you manually trawl through the repo and pull an rpm that looks semi-right it wont install.

  3. When building from source it doesn’t link to the provided Postgres libs (installed from Fedora’s repos and used successfully elsewhere).

Obviously there will be workarounds to the above-- particularly number 3, however I’ve been digging into it for a couple of days now and given there is no clear pathway following the published Timescale instructions. I am by no means a Fedora expert and am running on a fresh install as I’m trialing daily driving a new machine. Additionally I’ve just discovered that an automatically closed ticket exists inside github issues roughly on this topic that was originally opened in 2020… kinda frustrating.

Any suggestions on the best next steps?

I can imagine how frustrating it feels.

I think the best option would be have the fedora package available with both licenses. Can you create a github issue suggesting to package the fedora version too? more people can upvote and it can help to let it become a priority for the team.

It’s very hard to cover all the ground as the release matrix involves at least 3 dimensions: timescale, PG, OS versions. The 4th dimension would be OSS vs TSL licenses.

Have you tried docker?

1 Like

Ahah. Thanks for the quick and positive reply! I was a wee bit exhausted when I wrote the above :stuck_out_tongue:.

I can imagine how hard it is-- very much a moving target.

I tried docker but was having other issues (I’m still getting used to the different eccentricities non debian and / or apple ecosystem). I’ll give it another spin, and I just raised a bug with redhat / fedora so… I guess we’ll see how that goes. Of course its 100% possible that its deliberate because… licenses, in which case I’ve asked them to tell us.

Then at least we can get a note somewhere so that the next person does not need to go down the same rabbit-hole (and hopefully this thread is useful to that degree as well).


If anyone has been successful in getting a native install on Fedora still keen to hear it!

1 Like

Was able to get docker up and running so I’m unblocked, but I’ll track responses to the bugzilla here as well so the docs thing can be solved… somewhere :).

1 Like

Thanks for sharing and caring about the packaging :heart_hands:

Very good that you found your way, at least temporarily :whale: :smiley: