Compression after adding a new node

I have a postgres setup that uses 1 access node and 3 workers nodes. I’ve enabled compression on a distributed hypertable and it works. But, I’ve added a fourth worker node and the compression configuration is not applied to it. I don’t know how to enable compression for this node.

Hi Valentin, I think there’s no easy way to make it. You’d need to decompress to reenable compression or execute some routine in this machine to enable the compression in the proper way.

At this point we’ve seen too many small inconsistencies that can be leading to difficult issues with multi node. If you’re beta-testing it, consider use single node and embrace other strategies to expand your computing power like read replicas and so on.

I’m sorry for not having the best answer about multi-node but maybe in long term it can also simplifies a lot all your ecosystem.