Can't install timescaledb_toolkit

New to Timescale. But looks like what I need for a Rails app. I’m familiar with Postgres (barely). On macOS 14. Using the (not Brew installed as it’s better for other aspects of what I’m doing).
Following Set up the TimescaleDB extension I’ve got the timescaledb extension installed, but not the timescaledb_toolkit extension. From this doc seems like it is supposed to have been installed. Following the doc, I tried in a new database, examples, and got the same result.

➜  psql -U postgres -h localhost -d example
psql (16.1)
Type "help" for help.

example=# \dx
                                                List of installed extensions
    Name     | Version |   Schema   |                                      Description
 plpgsql     | 1.0     | pg_catalog | PL/pgSQL procedural language
 timescaledb | 2.13.0  | public     | Enables scalable inserts and complex queries for time-series data (Community Edition)
(2 rows)

I tried `shared_preload_libraries = ‘timescaledb, timescaledb_toolkit’ which didn’t help.
Where am I going wrong?

Hi @MtnBiker , the problem here is that this setup doesn’t include the toolkit.

The default way to install on macbook is through brew but you can also build it from scratch following the instructions from github: GitHub - timescale/timescaledb-toolkit: Extension for more hyperfunctions, fully compatible with TimescaleDB and PostgreSQL 📈

I’d like to chip in here as well. I run into a similar issue. I don’t think the documentation made it clear that the toolkit requires a separate installation.

I am also unable to install the toolkit as it requires a whole new dependency on rust and cargo-pgrx. Unfortunately, I am working in an isolated environment whereas I don’t have full internet connectivity to the outside world. Is there a way to install the toolkit in an isolated environment (like a single tar.gz file)? Thank you.

Noted @asiayeah ! thanks for the feedback.
@smitty is there any plans to fix it?

We have pre-built Debian packages and RPMs.

Thank you, @smitty

My environment is external network isolated and cannot connect to the remote TimeScale yum repository directly with DNF. That’s why I built the TimeScale from source but I still don’t have a good way to install the toolkit.

I don’t think this will help @asiayeah but How do you install timescaledb on MAC OS M1 (apple Silicone) if you have the installed ultimately worked for me. I say ultimately because I had many failed attempts and false starts. In part not understanding or taking the time to think about what was computer specific, Postgres specific and Rails app specific. He doesn’t say so and it’s obvious, but step 3.3 is psql, not command line. Many instructions overlook being specific about which environment you’re in. Slightly OT, but Rails is just straightening out making clear if you’re in irc or rails console both labeled irc. Important when you’re trying to debug or try out examples.